Salesforce

New runtime patch version is not reflected in Runtime Manager - Hybrid runtimes

« Go Back

Information

 
Content

SYMPTOM

After applying a new patch to an on-premise hybrid runtime the "Gateway version" in Runtime Manager still shows the old patch version, however, the mule-ee.log file confirms that the new patch was applied.
How to Validate that Mule Patches are Applied to a Mule Runtime

CAUSE

This is the expected behavior, as the server's runtime will be still a version X patched to Y. If there is a standalone runtime version for this patch, registering a server with it will show the new version in Runtime Manager, and the mule-ee.log will show no patch applied, as it will be a version Y.

Currently, Runtime Manager does not have this feature of displaying the cumulative patches and this is intentional. The reason being that the On-Prem used to have individual patches until the monthly cumulative patches was release as on Sept'2020 (where all the individual patches would be accumulated and released under a cumulative patch). So, there is a good possibility that there could be an individual patch along with the cumulative patch and hence the cumulative patch version is not displayed on the Runtime Manager UI.

SOLUTION

No need for corrective action, this is the expected behavior. Going forward, please update the runtime using the new Upgrade Tool that would eventually download a fresh new version of the runtime every month (not the cumulative patch) and that would solve the issue and display the Runtime version on the Runtime Manager UI.
Attachments

Powered by